HubSpot intermittent downtime
Incident Report for Sequin Status
Resolved
The HubSpot API intermittent outages seem to have resolved. API service has returned to normal operation, and so have our syncs and proxy requests. We'll continue to monitor the situation.
Posted Nov 20, 2023 - 09:44 PST
Identified
HubSpot's API seems to be experiencing an intermittent outage. Since about 5:30am PST, we've noticed periods of downtime for their API that last for about 5-10min (they return 500s). This incident is impacting all HubSpot syncs and proxy requests, and does not seem to be limited to particular HubSpot accounts or regions.

We've deployed some changes that ensure we backoff syncs less aggressively so that when HubSpot's API recovers, we more quickly resume syncing. We'll continue monitoring the situation and will update here when it seems these intermittent outages have resolved.
Posted Nov 20, 2023 - 07:43 PST
This incident affected: HubSpot sync & proxy.